ELAN — Toolbox — ELAN
WORKFLOW

Simon Devylder & Lucie Laporte-Devylder May 15t 2020

This document walks you through the steps needed when you want to collect your data for several speakers in
ELAN, then gloss it with Toolbox, and transfer the glossed data back into ELAN without losing any time-
encoded information.

1) Open file in ELAN [e.g. 1

- click “File” > “Export as” > “Tab-delimited Text”

-> select all tiers where the transcripts are recorded, for every speaker: “SPEAKER 1 SPEECH transcript”,
“SPEAKER 2 SPEECH transcript”, “SPEAKER 3 SPEECH transcript”, etc.

-> make sure the box “Exclude tier name from output” is not ticked

—> save under the name

% Export as tab-delimited text X
Export tier(s) as tab-delimited text

Select tiers
By Tier Names | By Types | By Participants | By Annotators = By Languages.

|_Depiction -

vI_Speaker 1 SPEECH transcript__|
Gesture Unit

Comments

Speaker 2 SPEECH transcript

Speaker 3 SPEECH transcript

| Depiction (semiotic ground)

| _Value -

Show only root tiers

A | ¥ | A-Z | Select All Select None

Output options
| Restrict to selected time interval
| Add master media time offset to annotation times

| Include header lines containing media file information

v| Exclude tier names from output

| Exclude participant names from output
| Separate column for each tier

OK Close

2) Open in Notepad

- click “Edit” > “Replace”
e in “Find what”, enter “Speaker 1 SPEECH transcript” (i.e the name of the tier for Speaker 1)
e in “Replace by”, enter “#” (i.e the # symbol plus a space)
- click “Replace all”
e repeat the operation, using a different symbol for every speaker
eg. “Speaker 1 SPEECH transcript” replaced by “#”
“Speaker 2 SPEECH transcript” replaced by “+”
“Speaker 3 SPEECH transcript” replaced by “* ”
etc.
e delete the added symbols for every first line (Speaker 1, line 1 ; Speaker 2, line 1 ; Speaker 3,
line 1;etc.)
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Your document should now look like this:

"1 SANDO_transeript - Notepad
File Edit Format View Help
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SPEECH transcript
SPEECH transcript
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SPEECH transcript
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SPEECH transcript
SPEECH transcript
SPEECH transcript

SPEECH transcript
SPEECH transcript
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SPEECH (transcription)
SPEECH (transcription)
SPEECH (transcription)

SPEECH (transcription)
SPEECH (transcription)
SPEECH (transcription)
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SPEECH (transcription)
SPEECH (transcription)
SPEECH (transcription)
SPEECH (transcriptien)
SPEECH (transcription)

eh... mete selus enga B
ehisenga ke? tovit six enga

koani ke kei ahite enga tin vatiteka

abowen keilu ke

vatikein ke vatin ke

suval

time uva alesi

umea suk suval ofala kei mulamun

4 3 4 4 A 4 W

kah kamitel ta koa kur guestion hema
kosa hehi komaitel vare

six tai tai ar vul te +
ehi case es i+

+

five en koani
keik kileh iko .

mete his tata Mathew mukone ke hel he
keinengani
kei haha kamitel enga ven

five ke?hehe

kovuli?

Bersi ehis ke?

start en start en tounah ta enga

o @ o

mulamu arsukul te enga ofala keil amu

amutis vareh muko

ka kihisi kesa ke sekeras vare rovalie keil akilea

kei vareh

maienga suk houlu umatmat tai heite e v

~ B2 3R 3% 2

Unix (LF) 100%

| SANDO6_transcript - Notepad - [u}

file Edit Format View Help

eh... mete selus enga

ehisenga ke? tovit six enga

koani ke kei ahite enga tin vatiteka

abowen keilu ke

vatikein ke vatin ke

suval

time uva alesi

umea suk suval ofala kei mulamun armutis tenga amutisi es tounah keil mukc

kah kamitel ta koa kur question hema hehisi
kosa hehi komaitel ware

six tal tai ar vul te

ehi case es

five en koani
keik kileh iko

mete his tata Mathew mukone ke hel helesi
keinengani
kei haha kamitel enga ven

five ke?hehe

kovuli?

Bersi ehis ke?

start en start en tounah ta enga

mulamu arsukul te enga ofala keil amumon vare koani

amutis vareh muko

ka kihisi kosa ke sekeras vare rovalia vaitnale vensa vare ke keil akilea
kei vareh

maienga suk houlu umatmat tai heite elu enga sesuk

Unix (LF) n1,Col 1

3) Open Toolbox

BEFORE

- click “File” > “New”
Create a new file and call it SANDO6
Select “Database Type” : “Text”

- next to \id marker, add “SANDO6” (without the quotation marks)

AFTER

- copy and paste all the lines from Speaker 1 (the lines that now have a # symbol at their start) from the
document SANDOG6 transcript.txt opened in Notepad in front of the \tx marker

W Toolbox - SANDOG
File Edit Database Project Tools Checks View Window Help

== S R R

@ 208 [motnen ]

\id SANDOS

~
Yref
\tx eh... mete selus enga
# ehisenga ke? tovit six enga
# koani ke kei ahite enga tin vatiteka
# abowen keilu ke
# vatikein ke vatin ke
# suval
# time uva alesi
# umea suk suval ofala kei mulamun armutis tenga amutisi es tounah
# sukulien tovuo
# ke
# tounah keil eke vasuval
# ka
# kitun heh kei ven )
B\ Dictionary bt
Ji \ps ‘\ge A
hiitaa v 38G:go.down
hinaa goup
hite v say
houlu adj many
botii M|

\id SANDOS \« eh... mete selus en

111 ‘Toolboxprujed pr Y

- click “Tools” > “Break/Number text”

in “Text-break punctuation”, enter “#”
click “use this name” and enter “SAND06_SP1”
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e in “starting number” check that “001” is entered

- click OK
Break and Number Text X l'
§ @ CutentRecod SANDO6 el

‘i " Whole Database

Qpbons:

Text-break Punctuation: ﬁ |

: Fields to be inchuded when breaking text
| Select Fields
|
Name of Text
{ " Use Contents of Field id Text Naine
| @ Use this Name: SANDOS_SP1 |
] | Starting Number [oo1 I E
Reference Marker re }
Text Marker. t

- click “Database” > “Insert Record” > name it SANDO6 SP2
-> copy and paste all the lines from Speaker 2 (the lines that now have a + symbol at their start) from the
document opened in Notepad in front of the \tx marker
- click “Tools” > “Break/Number text”
e in “Text-break punctuation”, enter “+”
o click “use this name” and enter “SANDO6_SP2”
e in “starting number” check that “001” is entered

- click OK
1 Break and Number Text X |
| ey o]
{ | @ Current Record SANDO6 SP2 Cancel
" Whole Database

Options:
H | Text-break Punctuation . I
i

Fields to be inchuded when breaking text:

Select Fields...

Name of Text:

| R
I " Use Contents of Field: Text Name
| & Use this Name: SANDOE_SP2 |

Stating Nurnber 001 l
Reference Marker: ref
Text Marker: ty

- repeat as many times as necessary, to eventually have 1 sheet per speaker (eg. If your file has 4 speakers
you should have 4 sheet: SANDO6 ; SANDO6 SP2 ; SANDO6 SP3 ; SANDO6 SP4)

Nb. Speaker 1 should have \ref markers that should look like this: SAND0O6_SP1.001

Nb. Speaker 2 should have \ref markers that should look like this: SAND0O6_SP2.001

Nb. Speaker 3 should have \ref markers that should look like this: SANDO6_SP3.001

etc.

— cut and paste the text with their \ref form every speaker into the first sheet where speaker 1 is (i.e the
sheet with the \id “SAND06"”)
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W iolbox - SANDUG
File Edt Database Project Tools Checks View Window Help

IR R R L e T —

- keep only the sheet with the \id “SAND06"”, delete every other sheet (i.e any sheet with an \id that include a
speaker name “SANDO6 SP2” , “SANDO6 SP3”, etc.). To do so, click on “Database” > “Delete record”, once you
are on the sheet you want to delete

Your Toolbox file should now look something like:
B Toolbox - SANDOG - ml X
File Edit Database Project Tools Checks View Window Help

EIEI Ll el =] ml 288 noien <

-~
_—

\id  |[SANDO6
yef |SANDO6_SP1.001
‘= | eh... mete selus enga #

yef | SANDO6_SP1.002

w | ehisenga ke? tovit six enga #
vef | SANDO6_SP1.003 SP1 here
w | koani ke kei ahite enga tin vatiteka #
yef | SANDO6_SP1.004

W | abowen keilu ke #

vef | SANDO6_SP1.005

‘e« | suval

yef | SANDO6_SP2.001

& | kah kamitel ta koa kur question hema hehisi +
yef || SANDO6_SP2.002

i« || kosa hehi komaitel vare + SP2 here
\ief || SANDO6_SP2.003

e | six tai tai ar vul te +
wef || SANDO6 SP2 004

\id here

‘ Dictionary.bxt E@
b ps \ge

hiitaa v 35G:go.down

hinaa v goup

hite v say

houlu adf many

ogli Ml

his e anmns i etart an ak 2 -

- click “File” > “Save” (i.e leave Toolbox open with the SANDOG6 file you just created)

4) Open again file in ELAN [SANDO6.eaf]

-> create a copy of this file in your working folder
-> click “Save as” > name it “SANDO6_toolexport”

-> in ELAN, under the Annotation mode, right click on “SPEAKER 1 SPEECH transcript”
> select “change attribute of”
e in “Tier name”, replace “SPEAKER 1 SPEECH transcript” by “ref@SP1”
e in “Participant”, add “SP1”
- click “Change”
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|
1

TR

% Change Tier Attributes X L
Change Tier Attributes
Current Tiers
|_Tier Name | Parent Tier | Tier Type | Participant ‘ Annctator | Input Methed Content La...
| |Depiction - Utterance English - =
Speaker 1... - Utterance English =
Gesture Unit - Utterance English
Comments - Utterance English - L
Speaker 2 ... - Utterance English - f
Speaker 3 ... - Utterance English - - | [
" Add | Change | Delete | Import !
T
Select Tier Speaker 1 SPEECH transcript ‘ b4 ‘
[_Tier Name ref@sP1 | | H
o[ Participant SP1 | | [ §
Annotator |
Parent Tier ‘
T
7| Tier Type Utterance "‘
T
Input Method English (United Kingdom) (System default) Ae ‘
T
|| Content Language None - - | "‘
; More Options...
Change | | Close

> repeat for each speaker

Speaker 2

Speaker 3

etc.

-> Tier name: ref@SP2
- Participant: SP2
-> Tier name: ref@SP3
- Participant: SP3

- click “Tier” > “Label and Number annotation”
select the tier now named “ref”
click “include label part” and enter “SAND06”

click “insert other delimiter” and enter “.

" n

Click “min number of integer digit” and enter “3”
Check that the label will look like “'SANDO6_SP1.001/" in the blue frame at the bottom of the

box

- click “OK” > “Close”

Generate label and number for annotations

Generate label and number for annotations
Select tier(s)
® single tier

O Multiple tiers

[? m.sm |

Gesture Unit

Comments

[ _ref@sp2

([ ret@sPa

Kl

ions
¥l Include label part NDOG_SP1 |

v| Insert delimiter

= ]
) Insert space characters 1

® Insert other delimiter B

| Include number part Integer ‘ v‘

v| Prepend leading zeros

® Minimal number of integer digits 3 |

) Minimal number of integer digits depends on number of annotations

Start value 1 { Increment 17 J\

SANDGB_SFW,(NJ;

CK I Close |

> repeat for every speaker, simply change the number in the case “include label part” : SANDO6_SP2
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Generate label and number for annotations X

Generate label and number for annotations

1 - Select tier(s)
® Single tier

O Multiple tiers

Gesture Unit

Comments

[ reisea

ref@SP3

Depiction (semiotic ground)
Ll Value

L] »

[4

Options:
J | ¥l Include label part NDos_sP2| I

¥| Insert delimiter
O Insert space characters I
® Insert other delimiter B
¥| Include number part m "]
¥| Prepend leading zeros
® Minimal number of integer digits 3:'.:{
© Minimal number of integer digits depends on number of annotations

Start value 1 { Increment 1] {

SANDOS_SP2.00 %—
OK Close

- click “File” > “Export” > “as Shoebox file”

e in “Select tier” select all speskers: “ref@SP1”, “ref@SP2”, “ref@SP3”, “ref@SP4”, etc.

e in “use Shoebox database type” select the database type “Text.typ”
[n.b. If you are using Windows, this file “Text.typ” is usually located in the folder where Toolbox is installed, in the folder
called “Toolbox New Project” > “Setting” > “Text.typ”]

e make sure the box “Encode all markers in Unicode (UTF-8)” is ticked

- click “OK”

X Export as Shoebox/Toolbox file e

Export as Shoebox/Toolbox file

I

Select tiers
| By Tier Names | By Types | By Participants = By Annotators | "By Languages |
[ _ret@sP1 N

= glish translation)
v| ref@sp2 .

__|_Speaker 2 (English translation)
vl ret@sP3 |
Speaker 3 LEninsh translation) =

Qutput options

| Wrap blocks
.Bﬂ characters per block
Time format
® hh:mm:ss.ms

O ss.msec
"Text.typ" usually follows the same file directory as here

] Add master media time offset to annotation times (i.e located in the same folder as indicated here)

Shoebox markers |
2=

®  Use Shoebox database type |C:\Program Files (x86)\ Toolbox\Toolbox New Project\Settings\Text.typ ‘ |

| |¥| Encode all markers in Unicode (UTF-8)

Define field markers... Specify Shoebox database type name
() Use ELAN tier names

[] Automatically generate marker file

| OK | Close |

- save under the name SANDO6 elanexport.txt (/!\ Make sure you select the file format “.txt”)

5) Open SANDO6 elanexport.txt in Notepad

— add manually “\id SAND06” above the line “\block 001”
(/)\ Make sure the is no space after “\id SAND06” {*“\id- SANDQs“})
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6) Open SANDO6 elanexport.txt in Toolbox
-> click “File” > “Open” > SANDO6_elanexport.txt

(/\\ Make sure here again that Toolbox did not add any space after “\id SANDO6” “\id-SANDO6-}}
(/!\ Make sure also that there isn’t any space in the \ref marker (e.g.“\ref SAND06.001” {net* “\ref SANDOS.001“)}
"1 Toolbox- SANDOS.canesportit - o x

File Edit Database Project Tools Checks View Window Help

S{@| L] || :;l.J_J__L_I&'ﬁ‘-& Wl

B8 o |[@ anexporttt = (£
\d | SANDO6 \id || SANDOS -
vef | SANDO6_SP1.001 \uockl 001 \
W |eh... mete selus enga # \ret s»'poo‘_‘sm 001
\ret s;ND“ SPIkOO; ik & \\Em 338‘3423 check here and remove any
W |ehisenga ke? tovit six enga e " ¢!
et |SANDO6_SP1.003 \ELAN| SP1 space before or after "SANDO6'
W |koani ke kei ahite enga tin vatiteka # \block | 002
Vel | SANDO6_SP1.004 \ret | SANDO6_SPX 001
W |abowen keilu ke # \ELAN| 00:00:12.054
\ef | SANDO6_SP1.005 \ELAN| 00:00:16.790
W |suval \ELAN| SPX
\ef | SANDO6_SP2.001
w |kah kamitel ta koa k tion h ock 92
ah kamite! oa kur question hema el | SANDO6_SP2.001
Vet | SANDO6_SP2.002 \ELAN| 00:00:16.606
w | kosa hehi komaitel vare + \ELAN| 00:00:19.470
\vel | SANDO6_SP2.003 \ELAN| SP2
\te six tai tai ar vul te + ¥
< > \block 004 v
———a |
You should now have in Toolbox :
B Toolbox - SANDOS - ] X
File Edit Database Project Tools Checks View Window Help
S[&| o] el o]l == m] B8 (o fneg -
-' SANDOS I EE:’T Q.[s;'nm-. elanexport bt | (e @] =
\id | SANDO] ~ ll[id  [SANDOS ~
\el | SANDO6_SP1.001 \block | 001
| eh... mete selus enga # \ref | SANDO6_SP1.001
el | SANDO6_SP1.002 :Em g&gg:i:
e |ehisenga ke? tovit six enga # .
\vef | SANDO6_SP1.003 \ELAN] SP1
= | koani ke kei ahite enga tin vatiteka # \block | 002
Vel |SANDO6_SP1.004 \ref | SANDO6_SPX 001
w | abowen keilu ke # \ELAN| 00:00:12.054
Vet | SANDO6_SP1.005 \ELAN| 00:00:16.790
w | suval \ELAN| SPX
Vet |SANDO6_SP2.001 block| 003
W |kah kamitel ta koa kur question hema el | SANDO6_SP2.001
Vet | SANDO6_SP2.002 \ELAN| 00:00:16.606
& | kosa hehi komaitel vare + \ELAN| 00:00:19.470
Vel | SANDO6_SP2.003 \ELAN| SP2
\te six tai tai ar vul te + i
< > \block | 004 v
B Dictionary e o|®=s
Wb \ps \ge ~
hiitaa v 35G:go.down
hinaa v go.up
hite v say
houlu adj many
buli |
\id SANDO6 \ start en ah & 47/49  Toolbox Projectprj 4

- click on the window of “SANDO06” that you created at step 3 (on the left in the picture above)
-> create a copy of it, click “File” > “Save as” > save under the name SANDO6 premerged.txt

-> click “Database” > “Merge database” > select “SANDO6_elanexport” > “OK”

You should now have in Toolbox :
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B Toolbox - SANDO6_premerged - a X
File Edit Database Project Tooks Checks View Window Help

@18 11215 «olel4] =) W] S0A] fomed ]
006 premerged o @ e B\ SANDOS_elanexporttt [ = || & [ ]
SANDOS = .

001 \block | 040

\ref | SANDO6_SP1.001 \ret | SANDO6_SP4.007
\ELAN( 00:00:00.558 \ELAN| 00:01:57.036
00:00:02.420 00:01:58.173

P - SP1 appears here gm SP4

\block | 043

\block | 040 \block | 041

ttbl:’;i gg: remove all \block markers EE'LAN go:m:ss_ﬁslpx'oos
\block | 037 \ELAN| 00:02:02.620

‘e |eh... mete selus enga # \ELAN| SPX

\ref | SANDOG6_SP1.002 block| 042

\ELAN| 00:00:35.287 \ELANParticipant is missing (here SP1) \re? SANDO6_SP1.015
i |ehisenga ke? tovit six enga # o prepees

SANDO06 SP1.003 .
Vet \ELAN| SP1

\ELAN| 00:01:08.125

:ELAN 00:01-14.029 \ELANParticipant is missing (here SP1) \plock | 043
. o u]
™ |koan! ke kel ahite enga tin vatiteka # \ef | SANDO6_SPX 006

vef | SANDO6_SP1.004 \ELAN| 00:02:07.835
\ELAN 00:01;15.7D1 \ELANParticipant is missing (here SP1) ém 2(11;2(2:14.300
& |abowen keilu ke # v v
hite v say
houlu adj many
W
}\ia SANDO6 [\u SANDO6 | 1/60 .TonlhnxProjectprj

-> close the window of the file “SANDO6_elanexport.txt” (on the right in the picture above)
-> in the window of the file “SANDO6_premerged”
o delete all “\block” markers (such as those framed in red in the picture above)

e add manually the marker \ELANParticipant with the relevant participant (“SP1”, “SP2”, “SP3”, etc.)
everywhere it is missing

e for clarity, move all \ELANMedia markers at the bottom of the file

Your Toolbox file is now ready to be interlinearized, and should look like this:

B Toolbox - SANDO6_merged - m] X
File Edit Database Project Tools Checks View Window Help

Z(E| [ 0]@ ][t =] ] 20048 [inofineq -

Yid SANDOS

‘\block 001

‘ref SANDO6_SP1.001

\ELANBegin | 00:00:00.558
\ELANEnd | 00:00:02.420

\ELANPartici| SP1
e eh... mete selus enga #
ret SANDO6_SP1.002

\ELANBegin | 00:00:35.287
\ELANEnd | 00:00:37.900

\ELANPartici| SP1
¢ ehisenga ke? tovit six enga #
\ret SANDO6_SP1.003

\ELANBegin | 00:01-08.125
\ELANEnd | 00:01:14.029

\ELANPartici| SP1

e koani ke kei ahite enga tin vatiteka #

et SANDO6_SP1.004

\ELANBeqgin | 00:01:15.701

‘ Dictionary.tt

Abe \ps ‘ge

hiitaa v 35G go.down
hinaa v go.up

hite v say

houlu ady many
hotii W ke ]

\id SANDOS \x SANDOB | 150 [ToolboxProjectpi p

-> click “File” > “Save as” > save under the name SANDO6 merged.txt
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7) Gloss your transcript in Toolbox

- add the “free translation” (marker “\ft”) after each transcription line
—> make sure to save regularly

8) Copy and paste into your working folder the file “Text.typ” from the folder Toolbox > Toolbox New Project >
Settings

- open “Text.typ” in Notepad
e replace the line “\mKrRecord id” by “\mKrRecord ref”
- save under the name “TextELAN”

9) Open ELAN

- click “Import” > “Shoebox file”
® in “Shoebox file” select the file SANDO6_merged.txt
e in “Shoebox database type” select the modified file from step 7: “TextELAN.typ”

o make sure “All marker are Unicode” is ticked
- 0K

% Import Shoebox X

IShoeboxﬁle LAN-Toolbox r'nerging‘.SANDOS_merged.txt]l ‘

| ® shoebox typ file D06 ELAN-Toolbox merging\liexlELAN.tyle

AII markers are Unicode

Import options
Default block duration (ms) ‘1000

|| Extract time from record marker

r] Scrub annotations on import

| OK | Cancel I

Example of ELAN file after you have imported the glossed transcript from Toolbox:
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% ELAN 5.5 - SANDO6_mergedbackup.txt

= a X
File Edit Annotation Tier Type Search View Options Window Help
L G ‘J’W Text | Subtitles | Lexicon r It g \VM [fe |
. \ v lret@unknown I'
s/ Nr | A | BeginTime | EndTime |  Duration
wnl  1/SANDOs_SP1.008 | 00:01:40.652| 00:01:45.610| 00:00:04.958
00:01:46.026 Selection: 00:01:40.652 - 00:01:45.610 4958

A E A o[ pE[ DA b [0 (bS] 8| ] (€] =] 4] 1] Cseoctonmote []ioopmode )

am e T P——r——— e ® e —
{smooc_mmz..[v 00:01:16.000 00:01:17.000 00:01:18.000 00:01:19.000 00:01:20.000 00:01:21.000 00:01:22.000 00:01:23.000 00:01:24.000 00:01:25.000 00:01:26.000 00

PRAL YT YT Y ) "
(S Lk et ) B ) s i

POPTI Ty
T

oy P B T v i e i o o e i o e s ] ey R i e R e e o 2,

@ lsJJ 00:01:16.000 00:01:17.000 00:01:18.000 00:01:19.000 00:01:20.000 00:01:21.000 00:01:22.000 00:01:23.000 00:01:24.000 00:01:25.000 00:01:26.000

mb@SP1 avoue  -n keilu eke vatik -n  eke vatu -n  eke
188] £

ge@SP1 wing -38G 3DL here tail -3S  here hea  -3S _ here
18]

PS@SP1 n -poss.aff, pron n n_ -pos.n n_ -pos.n
188

ft@sp1 the two wings are here its tail is here, its head is here
115]

ref@SP2 SANDO06 SP{ SANDO6_SP2.011
116]

x@SP2 vatiken vasuval nahisukes , vamuko  tounah eke K
169]

mb@SP2 vatike -n va- suva,n, hi -s, -s, va- muk, tounah eke K
1951

ge@SP2 tail  -3SG IMM-rese_1,a, -s IMM- do.li, thing here EE
w8 [ - b =0O——

GOOD LUCK ! &
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